«

»

Systemvakt gløymer minnekolonnen

Merknad: Dette innlegget er fleire år gammalt. Informasjonen kan vere utdatert og eg kan ha endra syn sidan då.

Eg har lengje hatt ein irriterande (men ufarleg) feil i Systemvakt (eller gnome-system-monitor som programmet eigentleg heiter). Eg liker å sortera på minne i prosessfana, men dei seinaste fem månadane har minnekolonnen ikkje vore der. Kvar gong eg startar Systemvakt på nytt, må eg gå inn på innstillingane og bla meg ned til minne for å velja det, berre for å sjå at det er vekke neste gong eg startar programmet. Det merkelege er at dette berre gjeld denne kolonnen. Eg har testa alle andre kolonnane, og dei fungerer. Til å byrja med var dette berre ein mild irritasjon, men etterkvart er det vorte særs frustrerande. No har eg endeleg funne ei løysing på dette.

Systemvakt utan minne

Feilen ligg visstnok i kolonnerekkjefølgja i fila for innstillingane. Eg veit ikkje kvar denne fila ligg, men eg veit korleis eg kan endra på den. Steng Systemvakt fyrst, slik at den ikkje skriv over endringane. Då er me jo like langt att. Kor som er, slik gjorde eg det:

  1. Opna gconf-editor 1, og leit opp /apps/procman/proctree.
  2. Nullstill (fjern) nøkkelen columns_order.
  3. Set nøkkelen col_15_visible som sann.
  4. Set nøkkelen col_15_width til t.d. 80.
  5. Steng gconf-editor og start Systemvakt.

Rekkjefølgja på kolonnane er sikkert feil, men går snøgt å fiksa. Neste gong Systemvakt startar, vil både minnekolonnen og evt. rekkjefølgje vera slik som me ynskjer. Hurra!

Systemvakt

  1. Køyr program-dialogen finn du på Alt + F2. []

2 comments

  1. Odin Hørthe Omdal

    Kolonnerekkjefylgja. Hmmm. At talet til den kolonna ikkje vert med då? Burde gå an å fiksa det i koden til procmanager.

    Hadde vore interessant å sjå på, kannhenda eg skal prøva meg.

  2. Simon

    Jo, talet til den kolonna var med, men av ein eller annan grunn fungerte det ikkje lell. Eg prøvde å setja den i ei anna rekkjefølgje, men kvar gong eg starta Systemvakt på nytt, vart col_15_visible set til usann. Løysinga med å fjerna columns_order var det einaste som fungerte. Denne nykelen vart gjenoppretta når Systemvakt starta, men då utan feilen.

Gje innspel